Killer Network Adapters and KRACK Exploit

5.0 

Killer Network Adapters and KRACK Exploit

We are aware of the current concern involving the KRACK vulnerabilities in WPA2-PSK Wi-Fi encryption.

All of our current line of network adapters are fully supported only on the current versions of Windows operating systems (Windows 10, 8.1, and 7). As this is a GTK Key exploit, our users are largely safe, as Microsoft has already patched these operating systems to address the issue (https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-13080), and the operating system is the primary key handling layer.

Have a question about your Killer product that isn't answered in our Knowledge Base?  Contact Us.